< Previous by Date Date Index Next by Date >
  Thread Index Next in Thread >

[reSIProcate-users] Help with Compiling resiprocate with TLS support



I’m using reciprocate version 1.10.2 and would like to use the TLS transport. I followed the instruction in the following link, where I added the USE_SSL pre-processor, but I still run into issues when I tried to compile the projects.




First of all, I realized some of the files are excluded from build in the Visual Studio project file (I’m using VC 9). For example, the OpenSSLInit.cxx is excluded from build for the ‘rutil’ project. This file seems needed for TLS support. After I added it to build, I run into the following 3 errors.


2>.\ssl\OpenSSLInit.cxx(69) : error C3861: 'CRYPTO_malloc_debug_init': identifier not found

2>.\ssl\OpenSSLInit.cxx(70) : error C2065: 'V_CRYPTO_MDEBUG_ALL' : undeclared identifier

2>.\ssl\OpenSSLInit.cxx(70) : error C3861: 'CRYPTO_set_mem_debug_options': identifier not found


I’m using openSSL version 1.1.0g.


Please advise.