< Previous by Date Date Index Next by Date >
  Thread Index  

[repro-users] Some bug regarding final ACK in 1.11.0~beta1-1 debian packaged version


I upgraded from Repro 1.10.2-1 packaged by Debian to 1.11.0 packaged by debian and it created a problem in a very specific context.

The context was an INCOMING call via AnveoDirect. The call comes in to repro, repro forwards it to Asterisk (on the same box as repro) and then Asterisk sets up a call with my various phones. When I answer the call the leg between Asterisk and my phones is fine, and RTP flows there, but Asterisk sends a 200/OK message back to Anveo to set up the leg between them, and Anveo receives this message, but the ACK from Anveo does NOT get back to Asterisk. Due to this Asterisk re-sends over and over until it gives up. No audio flows from Asterisk to Anveo's carrier, and after 32 seconds Asterisk terminates the call.

Downgrading to 1.10.2 package solved the problem immediately with no other changes required.

Things that didn't have this problem: calls between my own phones work fine going through Asterisk with repro as the proxy, and incoming calls from voip.ms also worked fine. So, it seems somehow specific to repro proxying the ACK message from Anveo back to Asterisk.

I recognize that this is probably hard to debug without a sample set-up, however if any developer wants to request directly sip traces I will send them both a working and a not working trace (From Anveo's end). I can't go back and sip trace on asterisk because I can't have these phone lines down any more than they already have been.

Thanks for this software, repro has been pretty darn solid up to this point.

Dan